Tips to help mitigate Lightroom 4.0 Performance Issues

A question I’m often asked is – why is that the first official release of Adobe Lightroom always seems to perform less well than the public beta? Well, I wish it were that I knew, but alas like many others I can only guess. The following are some tips based on personal experience and others I’ve read on Adobe’s Lightroom User to User forum. I don’t promise that they’ll solve any problems that you may be experiencing, but they should ease the pain a little.

Catalog Upgrade

When you install Lightroom 4 it will upgrade your existing Lightroom 3 catalog. This step is one that didn’t occur when you installed the beta because Adobe deliberately disabled this feature. Normally, the upgrade process shouldn’t cause any performance degradation, but occasionally something goes amiss with the result that Lightroom can feel seem somewhat slower than it did previously (e.g. switching modules, displaying metadata or badges). Usually, running the Optimise Catalog command is enough to fix things, but occasionally some additional effort  is required. For example, exporting the existing catalog as completely new catalog will remove all of the old crud left over from earlier versions of Lightroom whilst still retaining information such as Pick flags, Collections and develop adjustment History. The simplest way to do this is to select All Photographs in the Library Catalog panel, then choose Export as Catalog… from File menu, then configure the Export as Catalog dialog as shown below.  Choosing All Photographs ensures that the exported catalog will contain all of your photographs rather than only those that are selected. You can leave ‘Export negative files‘ option unchecked as the new catalog will automatically use the original negatives. I tend to prefer new previews when creating a new catalog as it a good way of freshening things. So, leaving ‘Include available previews‘ unchecked is also worth considering.

Export as Catalog…

Secondary Display and Video Drivers

Above tip regarding catalogs and previews, while useful, does not address some of the buggy behaviour that seems to have slipped into the GM version of Lightroom. In particular, the Develop module slider lags that many users are reporting when using a secondary display. Some Windows users, particularly those with nVidia graphics cards have reported that updating the video drivers helps, albeit only partially. So, if using a card from nVidia then it’s worth checking to see if the drivers for your card are up to date.

While Adobe hasn’t formally stated that theres a bug at work in Lightroom’s secondary display code I think it’s pretty clear that something is amiss. So, until the issue gets fixed my recommendation is to avoid using the secondary display when working in Develop module.

Other useful optimisation tips

To coincide with the release of Lightroom 4 Adobe updated their Performance Optimisation guide. This guide contains a wealth of tips from both Adobe and users. The guide can be accessed here.

This entry was posted in Adobe Photoshop Lightroom. Bookmark the permalink.